HDU 3555 Bomb

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3555


Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 15270    Accepted Submission(s): 5515



Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output

For each test case, output an integer indicating the final points of the power.
 

Sample Input

  
  
3 1 50 500
 

Sample Output

  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author

fatboy_cw@WHU
 

Source

 

Recommend

zhouzeyong


思路:经典的数位DP。自己不太懂这个知识点,参考了一位大神的博客,很详细,如下所示。

http://www.cnblogs.com/liuxueyang/archive/2013/04/14/3020032.html


附上AC代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 25;
ll dp[maxn][3];
int num[maxn];
ll n;

void init(){
	dp[0][0] = 1;
	for (int i=1; i<maxn; ++i){
		dp[i][0] = dp[i-1][0]*10-dp[i-1][1];
		dp[i][1] = dp[i-1][0];
		dp[i][2] = dp[i-1][2]*10+dp[i-1][1];
	}
}

int main(){
	init();
	int T;
	scanf("%d", &T);
	while (T--){
		scanf("%I64d", &n);
		ll ans = 0;
		bool ok = false;
		int len = 0;
		while (n){
			num[++len] = n%10;
			n /= 10;
		}
		for (int i=len; i>=1; --i){
			ans += dp[i-1][2]*num[i];
			if (ok)
				ans += dp[i-1][0]*num[i];
			if (!ok && num[i]>4)
				ans += dp[i-1][1];
			if (i+1<=len && num[i+1]==4 && num[i]==9)
				ok = true;
		}
		if (ok)
			++ans;
		printf("%I64d\n", ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值