poj 2456 最小值最大化

http://poj.org/problem?id=2456

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hi

/**
poj 2456   最小值最大化
题目大意:在编号为a0~an的n个点上放m个棋子要求如何防止能使距离最近的两个棋子的距离最大
解题思路:二分查找可行的值,贪心:对于每个可行值判断是否能在n个点中挑出m个。
          贪心的时候应该注意,我们只要从第一个开始就可以了,如果找不出来那么以第二个以及更后的开始就更找不出来了,因此每次贪心每个点最多考虑
          1次,复杂度O(n)
*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn=100003;

int a[maxn];
int n,c;

bool greed(int x)
{
    int cn=0;
    int p=a[0];
    for (int i=1; i<n; i++)
    {
        if (a[i]>=p+x)
        {
            cn++;
            p=a[i];
        }
    }
    if (cn>=c-1)
        return true ;
    return false ;
}

int main()
{
    while(~scanf("%d%d" ,&n,&c))
    {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int l=0,r=a[n-1],mid;
        while (l<=r)
        {
            mid=(l+r)/2;
            if(greed(mid))
                l=mid+1;
            else
                r=mid-1;
        }
        printf("%d\n" ,l-1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值