POJ-3268 Silver Cow Party[Dijkstra] [邻接矩阵] [置换矩阵]

Time Limit: 2000MS      Memory Limit: 65536K
Total Submissions: 21046        Accepted: 9625

Description:

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input:

Line 1: Three space-separated integers, respectively: N, M, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output:

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input:

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output:

10

Hint:

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source:

USACO 2007 February Silver

Tip:

这个题比较困难的地方是求从终点走回去的路,显然直接用Dijkstra一个一个的找是不现实的,基本退化到弗洛伊德的水平。其实把所有的路都倒过来,就是所谓的置换矩阵,能够求出每个点到起点距离。至于为什么,不怎么清楚。。。。=-=

Code:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#define N 1004
#define inf 0x3f3f3f
using namespace std;

int n,m,x;
int map[N][N];
int f[N],ff[N];
bool v[N];

int dij(int u){
    memset(v, false, sizeof(v));
    memset(f, inf, sizeof(f));

    f[u] = 0;

    for(int i = 0; i < n; i++){ //需要确认n个节点
        int min = inf , k;  //初始化

        for(int j = 1; j <= n; j++){   //寻找在确认节点集合外的 离起点最近的点 因为如果不是最近的点很可能有多个点的连接会改变路长
            if(!v[j] && f[j] < min){
                min = f[j]; k = j;
            }
        }

        v[k] = true; // 完成标记

        for(int j = 1; j <= n; j++){ // 如果没有第三点能改变他到起点的距离这个距离就是最短的。
            if(!v[j] && f[j] >  f[k] + map[k][j] )
                f[j] =f[k] + map[k][j];
        }


    }
    return f[1];
}


int main() {
    while(~scanf("%d%d%d", &n, &m, &x)){
        memset(map, inf, sizeof(map));
        for(int i = 0; i < m; i++ ){
            int d,g,v;
            cin >> d >>g >> v;
            map[d][g] = v;
        }

       dij(x);


       for(int i = 1; i <= n; i++)
          for(int j = 1; j <= n; j++){
            if(i < j){
                   int t;
                   t = map[i][j];
                   map[i][j] = map[j][i];
                   map[j][i] = t;
                }
            }



        for(int i = 1; i <= n; i++){
            ff[i] = f[i];
        }
        dij(x);

        int maxn = 0;
        for(int i =1 ; i <= n; i++){
            if(i != x)
               maxn = max(maxn, ff[i] + f[i]);
        }
        cout << maxn << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值