C - Fractal(3.4.1)

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
  • A box fractal of degree 1 is simply
    X
  • A box fractal of degree 2 is
    X X
    X
    X X
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-
解题思路:递归求解,找规律,确定每一次图形的右上角坐标,令左上角坐标为(0,0),可以发现对于第n个图形它的右上角坐标为3的(n-1)次幂减一;
对于每一个图形:它的形状为:
B(n - 1)        B(n - 1)

        B(n - 1)

B(n - 1)        B(n - 1)
对于每次递归先找出第一排对称的那两块中第一块的右上角坐标。经过五次递归变的全部图形。
size=1;
            for(k=2;k<n;k++)
                size*=3;
            df(n-1,x,y);
            df(n-1,x+size*2,y);
            df(n-1,x+size,y+size);
            df(n-1,x,y+2*size);
            df(n-1,x+2*size,y+2*size);
n=1;为终止条件。
代码:
#include <iostream>
using namespace std;
char map[1000][1000];
void df(int n,int x,int y)
{
    int size,k;
    if(n==1)
        map[x][y]='X';
    else
        if(n>1)
        {
            size=1;
            for(k=2;k<n;k++)
                size*=3;
            df(n-1,x,y);
            df(n-1,x+size*2,y);
            df(n-1,x+size,y+size);
            df(n-1,x,y+2*size);
            df(n-1,x+2*size,y+2*size);
        }
        return ;
}
int main()
{
    int n,i,i1,i2,k;
    while(cin>>n&&n!=-1)
    {
        int size;
        size=1;
        for(i=1;i<n;i++)
            size*=3;
        //图形初始化
        for(int i1=0;i1<size;i1++)
        {
            for(i2=0;i2<size;i2++)
                map[i1][i2]=' ';
            map[i1][i2]='\0';
        }
        df(n,0,0);
        for(k=0;k<size;k++)
            cout<<map[k]<<endl;
        cout<<'-'<<endl;
        
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值