分形图

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.

A box fractal is defined as below :

  • A box fractal of degree 1 is simply
    X
    
  • A box fractal of degree 2 is
    X X
     X
    X X
    
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
    B(n - 1)          B(n - 1)
             B(n - 1)
    B(n - 1)          B(n - 1)
    

Your task is to draw a box fractal of degree n.


Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer -1 indicating the end of input.


<b< dd="">

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case. Don't output any trailing spaces at the end of each line, or you may get an 'Presentation Error'!


<b< dd="">

Sample Input

1
2
3
4
-1

<b< dd="">

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X          X X   X X
 X     X            X     X
X X   X X          X X   X X
   X X                X X
    X                  X
   X X                X X
X X   X X          X X   X X
 X     X            X     X
X X   X X          X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X          X X   X X
 X     X            X     X
X X   X X          X X   X X
   X X                X X
    X                  X
   X X                X X
X X   X X          X X   X X
 X     X            X     X
X X   X X          X X   X X
-

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define LL long long
using namespace std;
char str[3000][3000];
char ss[3000][3000];
int hang[3000];
int n;
int Pow(int a,int k)
{
   int ans=1;
   for(int i=1;i<=k;i++)
   {
       ans*=a;
   }
   return ans;
}
void Draw(int x,int y,int cnt)
{
    if(cnt==1)
    {
        ss[x][y]='X';
        return ;
    }
    Draw(x,y,cnt-1);
    Draw(x-Pow(3,cnt-2),y+Pow(3,cnt-2),cnt-1);
    Draw(x+Pow(3,cnt-2),y+Pow(3,cnt-2),cnt-1);
    Draw(x-Pow(3,cnt-2),y-Pow(3,cnt-2),cnt-1);
    Draw(x+Pow(3,cnt-2),y-Pow(3,cnt-2),cnt-1);
}
int main()
{
    while(cin>>n)
    {
        memset(ss,' ',sizeof(ss));
        if(n==-1)
        {
            break;
        }
        if(n==1)
        {
            printf("X\n");
            printf("-\n");
            continue;
        }
        else
        {
            int k=Pow(3,n-2)+(Pow(3,n-2)+1)/2;
            Draw(k,k,n);
        }
        for(int i=1;i<=Pow(3,n-1);i++)
        {
            for(int j=Pow(3,n-1);j>=1;j--)
            {
                if(ss[i][j]=='X')
                {
                    hang[i]=j;
                    break;
                }
            }
        }
        for(int i=1;i<=Pow(3,n-1);i++)
        {
            for(int j=1;j<=hang[i];j++)
            {
                if(ss[i][j]=='X')
                {
                    printf("X");
                }
                else printf(" ");
            }
            printf("\n");
        }
        printf("-\n");
    }}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值