hdu 1069 Monkey and Banana

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9000    Accepted Submission(s): 4656


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
 


题意:

给你n种类型的积木,每种积木都有它的长宽高。问:用这些积木最多能堆多高?

分析:

每种积木都可以有三个不同规格的积木,长宽高互换一下就好。

现在就是先把这n种积木都这样处理一下,这样就会有3 * n个积木。

用结构体存下这些积木的信息,然后将这些积木按照底面积的大小排序(我是从大到小)

接着就是用到了动态规划,最长递增子序列

转移方程:dp[i] = max(dp[j] + block[i].hight, dp[i]);  

 (block[i].weight < block[j].weight && block[i].length < block[j].length)

dp[i]表示的是最上面的方块是第i号积木的积木堆的最大高度


#include<iostream>
#include<algorithm>

using namespace std;

const int MAXN = 100;

//积木结构体
struct Block {
    int l;
    int w;
    int value;
}block[MAXN];

bool cmp(Block a, Block b) {
    return a.l * a.w > b.l * b.w;
}

bool func(Block a, Block b) {
    if (a.l > b.l && a.w > b.w || a.l > b.w && a.w > b.l) {
        return 1;
    }
    else {
        return 0;
    }
}

int Max(int a, int b) {
    return a > b ? a : b;
}

int main() {
    int N;
    int a, b, c;
    int i, j;
    int maxhight;
    int dp[MAXN];
    int t = 1;

    while (~scanf("%d", &N) && N) {
        //每一种积木可以根据底面面积分成三种不同的积木
        for (i = 1; i <= N * 3; i++) {
            scanf("%d%d%d", &a, &b, &c);

            block[i].l = a;  block[i].w = b;  block[i].value = c;
            i++;
            block[i].l = b;  block[i].w = c;  block[i].value = a;
            i++;
            block[i].l = c;  block[i].w = a;  block[i].value = b;
        }

        sort(block + 1, block + 1 + N * 3, cmp);

        for (i = 1; i <= N * 3; i++) {
            dp[i] = block[i].value;

            for (j = i - 1; j >= 1; j--) {
                if (func(block[j], block[i])) {
                    dp[i] = Max(dp[i], dp[j] + block[i].value);
                }
            }
        }

        maxhight = -1;

        for (i = 1; i <= N * 3; i++) {
            if (dp[i] > maxhight) {
                maxhight = dp[i];
            }
        }

        printf("Case %d: maximum height = %d\n", t++, maxhight);
    }

    return 0;
}

/*
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
*/
基于SSM框架的智能家政保洁预约系统,是一个旨在提高家政保洁服务预约效率和管理水平的平台。该系统通过集成现代信息技术,为家政公司、家政服务人员和消费者提供了一个便捷的在线预约和管理系统。 系统的主要功能包括: 1. **用户管理**:允许消费者注册、登录,并管理他们的个人资料和预约历史。 2. **家政人员管理**:家政服务人员可以注册并更新自己的个人信息、服务类别和服务时间。 3. **服务预约**:消费者可以浏览不同的家政服务选项,选择合适的服务人员,并在线预约服务。 4. **订单管理**:系统支持订单的创建、跟踪和管理,包括订单的确认、完成和评价。 5. **评价系统**:消费者可以在家政服务完成后对服务进行评价,帮助提高服务质量和透明度。 6. **后台管理**:管理员可以管理用户、家政人员信息、服务类别、预约订单以及处理用户反馈。 系统采用Java语言开发,使用MySQL数据库进行数据存储,通过B/S架构实现用户与服务的在线交互。系统设计考虑了不同用户角色的需求,包括管理员、家政服务人员和普通用户,每个角色都有相应的权限和功能。此外,系统还采用了软件组件化、精化体系结构、分离逻辑和数据等方法,以便于未来的系统升级和维护。 智能家政保洁预约系统通过提供一个集中的平台,不仅方便了消费者的预约和管理,也为家政服务人员提供了一个展示和推广自己服务的机会。同时,系统的后台管理功能为家政公司提供了强大的数据支持和决策辅助,有助于提高服务质量和管理效率。该系统的设计与实现,标志着家政保洁服务向现代化和网络化的转型,为管理决策和控制提供保障,是行业发展中的重要里程碑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值