The Triangle
时间限制:
1000 ms | 内存限制:
65535 KB
难度:
4
-
描述
-
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.-
输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99. 输出
- Your program is to write to standard output. The highest sum is written as an integer. 样例输入
-
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
样例输出
-
30
#include<stdio.h> #include<string.h> #define maxn 100+5 // #define max(a,b) a>b?a:b int max(int a,int b) { return a>b?a:b; } int dp[maxn][maxn]; int main() { int n,i,j; scanf("%d",&n); memset(dp,0,sizeof(dp)); for(i=1;i<=n;i++) { for(j=1;j<=i;j++) { scanf("%d",&dp[i][j]); } } for(i=n;i>=1;i--) { for(j=1;j<=i;j++) { dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+dp[i][j];
/*求解释
当用注释掉的宏定义#define max(a,b) a>b?a:b;时,
dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+dp[i][j];
dp[i][j]+=max(dp[i+1][j],dp[i+1][j+1])+dp[i][j];
dp[i][j]=dp[i][j]+max(dp[i+1][j],dp[i+1][j+1]);
为什么这三者运行结果都不一样呢?
*/
}
}
printf("%d\n",dp[1][1]);
return 0;
}