poj2229 Sumsets

Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 12693 Accepted: 5092

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6
/*
dp题,参考别人代码
奇数:dp[i]=dp[i-1];只有后边加个1这一种状态
偶数:dp[i]=dp[i-1]+d[i/2]在后边加两个1即和i-1一样,或者i-2加个2即相当于求2的次方组成的个数,相当于用i/2求1的次方组成的个数
注意:预处理要将数组定义到外边
Time:2014-8-3 13:26
*/
#include<stdio.h>
#include<string.h>
const int MAX=1000000+10;
const int mod=1000000000;
long long a[MAX]={0,1};
int main()
{	
	
	for(int i=2;i<MAX;i++)
	{	
		if(i&1)
		a[i]=a[i-1];
		else
		a[i]=(a[i/2]+a[i-1])%mod; 
	}
	long long  n;
	while(scanf("%lld",&n)!=EOF)
	printf("%lld\n",a[n]);
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值