杭电1306 String Matching

String Matching

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 902    Accepted Submission(s): 465


Problem Description
It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:

CAPILLARY
MARSUPIAL

There is only one common letter (A). Better is the following overlay:

CAPILLARY
   MARSUPIAL

with two common letters (A and R), but the best is:

  CAPILLARY
MARSUPIAL

Which has three common letters (P, I and L).

The approximation measure appx(word1, word2) for two words is given by:

common letters * 2
-----------------------------
length(word1) + length(word2)

Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.
 

Sample Input
  
  
The input for your program will be a series of words, two per line, until the end-of-file flag of -1. Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. For example: CAR CART TURKEY CHICKEN MONEY POVERTY ROUGH PESKY A A -1 The words will all be uppercase.
 

Sample Output
  
  
Print the value for appx() for each pair as a reduced fraction, like this: appx(CAR,CART) = 6/7 appx(TURKEY,CHICKEN) = 4/13 appx(MONEY,POVERTY) = 1/3 appx(ROUGH,PESKY) = 0 appx(A,A) = 1
/*
郁闷,本来很简单的一道题,,一直搞的wa必须用长的匹配短的,再用短的匹配长的,匹配2次。。。。无语上午测试就没搞出来,真丢人

*/
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int gcd(int a,int b){
	if(b==0) return a;
	else return gcd(b,a%b);
}
int main(){
	string str1,str2;
	string s1,s2;
	while(cin>>str1!=NULL){
		if(str1=="-1")break;
		cin>>str2;/*
		if(str1.length()>str2.length()){//可以去掉
			s1=str1;s2=str2;
		}else{
			s1=str2;s2=str1;
		}*/
		int l1=s1.length();
		int l2=s2.length();
		int i,j,k,sum;
		int fz,fm;
			k=0;fz=0;
			while(k<l1){
				sum=0;
				for(i=k,j=0;i<l1&&j<l2;++i,++j){
					if(s1[i]==s2[j]){sum++;}
				}	
				//printf("sum=%d\n",sum);
				fz=max(fz,sum);
				k++;
			}
			k=0;
			while(k<l2){/第二次匹配
				sum=0;
				for(i=k,j=0;i<l2&&j<l1;++i,++j){
					if(s2[i]==s1[j]){sum++;}
				}	
				//printf("sum=%d\n",sum);
				fz=max(fz,sum);
				k++;
			}
			fz<<=1;	
			
			if(fz==0){cout<<"appx("<<str1<<","<<str2<<") = 0"<<endl;
						continue;}
				fm=l1+l2;int x=gcd(fz,fm);fm/=x;fz/=x;
			 if(fz==fm)
			 cout<<"appx("<<str1<<","<<str2<<") = 1"<<endl;
			 else{	
				cout<<"appx("<<str1<<","<<str2<<") = "<<fz<<"/"<<fm<<endl;
			}
		s1.clear();s2.clear();str1.clear();str2.clear();
	}
return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值