poj3984 迷宫问题(BFS)

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7902 Accepted: 4649

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
/*
做了hdu1026 这就是一道水题,而且我看讨论区说这题数据弱爆了,就一组测试数据,不过以前还是不会做
Time:2014-8-24 13:31
*/
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node{
	int x,y;
	int time;
	friend bool operator<(node a,node b){
		return a.time>b.time;
	}
}cur,next;
struct Node{
	int x;
	int y;
	
}path[7][7];
bool map[7][7];
int move[4][2]={0,1,0,-1,1,0,-1,0};
bool Judge(int x,int y){
	if(x>=0&&x<5&&y>=0&&y<5&&!map[x][y]) return true;
	
	return false;
}
void BFS(int ×){
	cur.x=cur.y=cur.time=0;
	priority_queue<node> pq;
	pq.push(cur);
	while(!pq.empty()){
		cur=pq.top();pq.pop();
		if(cur.x==4&&cur.y==4) {
		times=cur.time;
		return;
		}
		for(int i=0;i<4;i++){
			next=cur;
			next.x+=move[i][0];
			next.y+=move[i][1];
			if(Judge(next.x,next.y)){
				map[next.x][next.y]=1;
				next.time++;
				path[next.x][next.y].x=cur.x;
				path[next.x][next.y].y=cur.y;
				pq.push(next);
			}
		} 
	}
}
void printPath(int times,int x,int y){
	if(times==0){
	printf("(0, 0)\n");
	return;}
	printPath(times-1,path[x][y].x,path[x][y].y);
	printf("(%d, %d)\n",x,y);
} 
void solve(){
	int times;
	for(int i=0;i<5;i++){
		for(int j=0;j<5;j++){
			scanf("%d",&map[i][j]);
		}
	}
	BFS(times);
	printPath(times,4,4);
}
int main(){
	solve();	
return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值