杭电1250 Hat's Fibonacci(大数+1000进制输出)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7853    Accepted Submission(s): 2550


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
/*
这道题的收获之处主要是会处理大数的10000进制,以后遇到情况可以处理,加油!!
Time:2014-10-20 8:07
*/
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define MAX 10000+10
#define MM 300
#define SYS 10000000
int dig[MAX]={0,0,0,0,0};
int f[MAX][300];
void Get_f(){
	memset(f,0,sizeof(f));
	f[1][0]=1;f[2][0]=1;f[3][0]=1;f[4][0]=1;
	for(int i=5;i<MAX;i++){
		int t=0;
		for(int j=0;j<MM;j++){
			f[i][j]+=(t+f[i-1][j]+f[i-2][j]+f[i-3][j]+f[i-4][j]);
			t=f[i][j]/SYS;
			f[i][j]%=SYS;
		}
	}
}
int main(){
	int n,i;
	 Get_f();
	while(scanf("%d",&n)!=EOF){
		i=MM-1;
		while(f[n][i]==0)i--;
		printf("%d",f[n][i--]);//输出后-- 
		for(;i>=0;i--)
		printf("%07d",f[n][i]);
		puts("");
	}
return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值