杭电1250Hat's Fibonacci

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9134    Accepted Submission(s): 2970


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 

Author

妥妥的水题,但是要是存二维数组,第二维只存一位数的话会超内存的,超了3次才想到存4位数;所以第二维只需要开到2005/4即可;一维开到8000即可.

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 2010
int a[7061][555];
int i,n,m,j,k,l;
int main()
{
	memset(a,0,sizeof(a));
	 a[1][0]=a[2][0]=a[3][0]=a[0][0]=1;
	 for(i=4;i<7060;i++)
	 {
	 	k=0;
	 	for(j=0;j<555;j++)
	 	{
	 		a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j]+k;
	 		k=a[i][j]/10000;
	 		a[i][j]=a[i][j]%10000;
		 }
	 }
	 while(scanf("%d",&n)!=EOF)
	 {
	 	j=550;
	 	while(a[n-1][j]==0)
		j--;
		printf("%d", a[n-1][j--]);//这一位不一定是四位数,所以输出%d 
		for(; j>=0; j--)
		printf("%04d", a[n-1][j]);//剩下的一定是4位数的,所以输出%04d,否则就会错.!!!!!! 
		putchar('\n');
		//printf("%d",a[n-1][j]);//这的输出也是ac代码; 
		//i=j-1;//个人比较喜欢下边的输出 
		//for(i=j-1;i>=0;i--)
		//printf("%04d",a[n-1][i]);
		//printf("\n"); 
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值