poj1149 PIGS(网络流)

PIGS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16859 Accepted: 7563

Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs. 
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold. 
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses. 
An unlimited number of pigs can be placed in every pig-house. 
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N. 
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000. 
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line): 
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7

Source

Croatia OI 2002 Final Exam - First day
/*
郭炜的暑期资料讲的挺详细的。。
构图难,难于上青天。....万能的网络流
Time:2014-12-19 12:37
*/
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int INF=1<<28;
const int MAX=1010;
int n,m;
int g[MAX][MAX];
int pigs[MAX],d[MAX],house[MAX];
bool BFS(int s,int t){
    queue<int>q;
    memset(d,-1,sizeof(d));
    q.push(s);d[s]=0;
    while(!q.empty()){
        int u=q.front();q.pop();
        for(int v=1;v<=n+1;v++){
            if(g[u][v]>0&&d[v]==-1){
                d[v]=d[u]+1;
                q.push(v);
            }
        }
    }
    return d[t]!=-1;
}
int DFS(int u,int cur_flow){
    if(u==n+1) return cur_flow;
    int temp=cur_flow;
    for(int v=0;v<=n+1;v++){
        if(g[u][v]>0&&d[u]+1==d[v]){
            int flow=DFS(v,min(temp,g[u][v]));
            g[u][v]-=flow;
            g[v][u]+=flow;
            temp-=flow;
        }
    }
    return cur_flow-temp;
}
int Dinic(int s,int t){
    int flow=0;
    while(BFS(s,t)){
            int temp;
        while(temp=DFS(s,INF)){
            flow+=temp;
        }
    }
    return flow;
}
int main(){
    while(scanf("%d%d",&m,&n)!=EOF){
        int sour=0,des=n+1;
        for(int i=1;i<=m;i++){
            scanf("%d",&pigs[i]);//i个猪圈里边猪的个数
        }
        memset(g,0,sizeof(g));
        memset(house,0,sizeof(house));
        int keys,id;
        for(int i=1;i<=n;i++){
            scanf("%d",&keys);
            while(keys--){
                scanf("%d",&id);//猪圈编号
                if(!house[id]){//第一次打开
                    g[sour][i]+=pigs[id];
                }else{
                    g[house[id]][i]=INF;
                }
                house[id]=i;//维护上一个打开猪圈的顾客编号
            }
            scanf("%d",&g[i][des]);//顾客到终点连一条边
        }
        printf("%d\n",Dinic(sour,des));
    }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值