Accept: 513 Submit: 1996
Time Limit: 1000 mSec Memory Limit : 32768 KB
Problem Description
Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)
You can assume that the grass in the board would never burn out and the empty grid would never get fire.
Note that the two grids they choose can be the same.
Input
The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.
1 <= T <=100, 1 <= n <=10, 1 <= m <=10
Output
For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.
Sample Input
Sample Output
/*
题目大意:“#”表示草地,“.”表示空地,草地可以燃烧,问的是找任意两个点同时开始扩散,求最少扩散完全部草地的步数,如果不存在,输出-1
打了好久的2014 突然改成2015,好不适应 加油!!!
Tme:2015-1-1 17:33
*/
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAX=1000;
struct Node{
int x,y;
int cnt;
};
vector<Node>v;
int move[][2]={0,1,0,-1,1,0,-1,0};
char g[12][12];
bool vis[12][12];
int n,m;
int BFS(Node a,Node b){
queue<Node>q;
memset(vis,0,sizeof(vis));
vis[a.x][a.y]=vis[b.x][b.y]=true;
int ret=INF;
q.push(a);q.push(b);//只要刚开始将两个起点进队就能满足从小到大搜索
while(!q.empty()){
a=q.front(); q.pop();
ret=a.cnt;
//队列中都是覆盖到的位置,最大的cnt就是最少的步数,因为覆盖后后边就不在访问
for(int i=0;i<4;i++){
b.x=a.x+move[i][0];
b.y=a.y+move[i][1];
if(b.x>=0&&b.x<n&&b.y>=0&&b.y<m
&&g[b.x][b.y]=='#'&&vis[b.x][b.y]==0){
b.cnt=a.cnt+1;
q.push(b);
vis[b.x][b.y]=true;
}
}
}
return ret;
}
int main(){
int T,nCase=1;
scanf("%d",&T);
while(T--){
v.clear();//记得清空,后果自负
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++){
scanf("%s",g[i]);
for(int j=0;j<m;j++){
if(g[i][j]=='#'){
v.push_back((Node){i,j,0});
}
}
}
int ans=INF;
for(int i=0;i<v.size();i++){
for(int j=i;j<v.size();j++){//从i开始,避免了一个点的时候特判
bool flag=true;
int temp=BFS(v[i],v[j]);
for(int k=0;k<n;k++){//判断是否有访问不到的点
for(int l=0;l<m;l++){
if(g[k][l]=='#'&&vis[k][l]==0){
flag=0;break;
}
}
if(!flag)break;
}
if(flag) ans=min(ans,temp);
}
}
if(ans==INF){
printf("Case %d: -1\n",nCase++);
}else{
printf("Case %d: %d\n",nCase++,ans);
}
}
return 0;
}