Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 7198 | Accepted: 3979 |
Description
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5 4 3 4 2 3 2 1 2 2 5
Sample Output
2
Source
/*
本来想用拓扑排序解决呢,后来想了想不好确定关系的个数,搜了一下发现都是用的Floyd判断的,floyd跑一次,两个方向g[x][y]或者g[y][x]确定 的话,这两个关系就能确定啦,如果一个能与其他的N-1个关系确定的话,那么这个关系就能确定
Time:2015-1-5 16:32
*/
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int MAX=200;
int g[MAX][MAX];
int main(){
int n,m;
int u,v;
while(scanf("%d%d",&n,&m)!=EOF){
memset(g,0,sizeof(g));
while(m--){
scanf("%d%d",&u,&v);
g[u][v]=1;
}
for(int k=1;k<=n;k++){
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
if(g[i][k]&&g[k][j])
g[i][j]=1;
}
}
}
int num,ans=0;
for(int i=1;i<=n;i++){
num=0;
for(int j=1;j<=n;j++){
if(g[i][j]||g[j][i])num++;
}
if(num==n-1)ans++;
}
printf("%d\n",ans);
}
return 0;
}