Cow Contest POJ - 3660

Description
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
 
Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

题意与思路:

题意是给出m对牛的相互关系,求有多少个牛排名是确定的。

用floyed求传递闭包就可以了,因为题上面给的数据n<=100,三层for循环是可以的。如果一个牛和其余的牛关系都是确定的,那么这个牛的排名就是确定的了。

代码如下:

#include<stdio.h>
#include<string.h>
int n,m;
int a,b;
int book[120][120];
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        memset(book,0,sizeof(book));
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d",&a,&b);
            book[a][b]=1;//标记关系,当做最短路求,是单向的
        }
        for(int i=1; i<=n; i++)//floyed的经典三层for循环
            for(int j=1; j<=n; j++)
                for(int k=1; k<=n; k++)
                    if(book[j][i]&&book[i][k])
                        book[j][k]=1;
        int sum=0;
        for(int i=1; i<=n; i++)
        {
            int ans=0;
            for(int j=1; j<=n; j++)
            {
                if(book[i][j]||book[j][i])//判断与其可以确立关系的有几个
                    ans++;
            }
            if(ans==n-1)//满足n-1个才可以完全确立排名
                sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值