spoj104 Highways(生成树计数模板)

SPOJ Problem Set (classical)

104. Highways

Problem code: HIGH

In some countries building highways takes a lot of time... Maybe that's because there are many possiblities to construct a network of highways and engineers can't make up their minds which one to choose. Suppose we have a list of cities that can be connected directly. Your task is to count how many ways there are to build such a network that between every two cities there exists exactly one path. Two networks differ if there are two cities that are connected directly in the first case and aren't in the second case. At most one highway connects two cities. No highway connects a city to itself. Highways are two-way.

Input

The input begins with the integer t, the number of test cases (equal to about 1000). Then t test cases follow. The first line of each test case contains two integers, the number of cities (1<=n<=12) and the number of direct connections between them. Each next line contains two integers a and b, which are numbers of cities that can be connected. Cities are numbered from 1 to n. Consecutive test cases are separated with one blank line.

Output

The number of ways to build the network, for every test case in a separate line. Assume that when there is only one city, the answer should be 1. The answer will fit in a signed 64-bit integer.

Example

Sample input:
4
4 5
3 4
4 2
2 3
1 2
1 3

2 1
2 1

1 0

3 3
1 2
2 3
3 1

Sample output:
8
1
1
3


Added by:Piotr Łowiec
Date:2004-07-02
Time limit:7s
Source limit:50000B
Memory limit:1536MB
Cluster:Cube (Intel Pentium G860 3GHz)
Languages:All except: SCM chicken
/*
提前学线代了。。。。真蛋疼。。。
Time:2015-1-27 17:45
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=20;
bool zero(double x){
    return (x>0?x:-x)<1e-15;//如果x为0,返回true,否则返回false
}
double deg[MAX];
double g[MAX][MAX];
double b[MAX][MAX];
double Det(int n){
    int i,j,k;
    int sign=0;
    double ret=1;
    for(i=1;i<=n;i++){
        if(zero(b[i][i])){
            j=i+1;
            while(zero(b[j][i])&&j<=n){//找不为0的一行替换
                j++;
            }
            if(j>n)return 0;//如果大于n,说明对角线一定有一个0,
            for(k=i;k<=n;k++){
                swap(b[i][k],b[j][k]);
            }
            sign++;
        }
        if(zero(b[i][i])) return 0;

        ret*=b[i][i];

        for(j=i+1;j<=n;j++){
            double tmp=b[j][i]/b[i][i];
            for(k=i+1;k<=n;k++){
                b[j][k]-=tmp*b[i][k];
            }
        }
    }
    if(sign&1) ret=-ret;
    return ret;
}
int main(){
    int T,n,m;
    int u,v;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        memset(deg,0,sizeof(deg));
        memset(g,0,sizeof(g));
        memset(b,0,sizeof(b));
        while(m--){
            scanf("%d%d",&u,&v);
            g[u][v]=1;g[v][u]=1;
            deg[u]++; deg[v]++;
        }
        for(int i=1;i<=n;i++){
            b[i][i]=deg[i];
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                b[i][j]-=g[i][j];
            }
        }
        /*for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                printf(" %.0lf",b[i][j]);
            }puts("");
        }*/
        printf("%.0lf\n",Det(n-1));//传入的是n-1,任意n-1阶就行
    }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值