【动态规划】【2014 Multi-University Training Contest 4】Our happy ending

Our happy ending


Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 882    Accepted Submission(s): 284




Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.


Y*wan still remember the day he first meets the devil. Now everything is done and the devil is gone. Y*wan feel very sad and suicide.


You feel guilty after killing so many loli, so you suicide too.


Nobody survive in this silly story, but there is still some hope, because this is just a silly background story during one programming contest!


And the last problem is:


Given a sequence a_1,a_2,...,a_n, if we can take some of them(each a_i can only be used once), and they sum to k, then we say this sequence is a good sequence.


How many good sequence are there? Given that each a_i is an integer and 0<= a_i <= L.


You should output the result modulo 10^9+7.
 


Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains 3 integers n, k, L.


T<=20, n,k<=20 , 0<=L<=10^9.
 


Output
For each cases, output the answer in a single line.
 


Sample Input
1
2 2 2
 


Sample Output
6

 

大致题意:还是只用看后三段,随便构造一个长度为n的数列,使得其中某些数加起来=k,每个数字要满足小于等于L,这样的数列叫做good sequence,问一共有多少good sequence


思路:n,k<=20,这种范围不是搜索就是状压,仔细想了一下就朝着状压dp去搞了。搞的过程简直不忍多说了……

反正设计状态:f[i][j]表示数列长度为i时,到达状态j的方案总数,状态j的意思是0..k中的数是否到达,到达过为1,没有则为0,20位状态压缩为一个j 。

那么转移为:f[i+1][j]=sum{f[i][pre]},如果有r<l,那么还需要有f[i+1][j]+=(l-r)*f[i][j]。

因为i<=20,j<=(1<<(k+1))-1,所以如果开一个maxi*maxj的数组,不管从空间和时间来说,都是无法接受的,所以就应该开成滚动数组。


比较坑爹的是:我写了个01滚动,各种TLE,也是醉了,队友当时也在写这道题,但是没搞出来,那就没办法,只有我来继续搞了,因为实在是想不到好的方法,只有各种姿势跪求卡过,比如01滚动的所有%2都改成&1,不过,g++改成VC++,不过,各种瞎优化,还是不过……逼得没办法了最后默默地改成了就地滚动,纠结了下枚举顺序,改好之后居然过了。。。过了。。。了。。。何等的卧槽……


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;

int n,k,l;
long long f[(1<<21)+10];
const long long mod=1e9+7;

int main(){
    int t;
    scanf("%d",&t);
    while (t--){
        scanf("%d%d%d",&n,&k,&l);

        memset(f,0,sizeof(f));
        int r=min(l,k);
        int tot=(1<<(k+1))-1;

        f[1]=1;
        for (int i=1;i<=n;i++){
            //for (int j=1;j<=20;j++) cout<<f[i%2][j]<<" ";
            //cout<<endl;
            for (int j=tot;j>0;j--){
                if (f[j]==0) continue;

                long long pre=f[j];

                for (int t=1;t<=r;t++){
                    int tmp=(j|(j<<t));

                    //if ((tot & tmp)==3) cout<<"111get!! "<<i<<" "<<j<<" "<<t<<endl;
                    f[tot & tmp]=(f[tot & tmp]+pre)%mod;

                }

                if (r<l){
                    f[j]=(((l-r)*pre)%mod+f[j])%mod;
                }
            }
        }

        //for (int i=1;i<=20;i++) cout<<f[(n+1)%2][i]<<" ";
        //cout<<endl;

        long long ans=0;
        for (int i=1;i<=tot;i++){
            if (i & (1<<k)) ans=(ans+f[i])%mod;
        }

        printf("%I64d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值