Corn Fields

Corn Fields

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 17   Accepted Submission(s) : 13
Problem Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

 

Input
Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
 

Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
 

Sample Input
  
  
2 3 1 1 1 0 1 0
 

Sample Output
  
  
9
 

Source
PKU
 
#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<set>
#include<string>
#include<algorithm>
using namespace std;
int map[13],stk[400]; /// stk[i]  表示第  i 种状态  约 377
int dp[13][400];
int fun(int x)   ///  判断相邻是否含有 1
{
    if(x&(x<<1)) return 0;
    return 1;
}
int fun1(int n) ///  初始化每行所有可能  合法状态
{
    int a=0;
    memset(stk,0,sizeof(stk));
    for(int j=0; j<(1<<n); j++)
    {
        if(fun(j)) stk[a++]=j;
    }
    return a;  ///  总状态数   从0状态开始
}
int main()
{
    int m,n,a;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(map,0,sizeof(map));
        for(int i=1; i<=m; i++) ///   制出不能放牧的的图
        {
            for(int j=0; j<n; j++)
            {
                cin>>a;
                if(a==0) map[i]|=(1<<j);
            }
        }
        a=fun1(n);  ///   每行初始总状态数 从0 开始
        memset(dp,0,sizeof(dp));
        for(int i=0; i<a; i++)
        {
            if(!(stk[i]&map[1])) ///  表示  stk[i] 状态能放牧
            {
                dp[1][i]=1;  ///第一行 状态为  stk[i] 时 满足条件的 总数
            }
        }
        for(int i=2; i<=m; i++)  ///  行数
        {
            for(int j=0; j<a; j++) /// 要求该行有效状态
            {
                if(stk[j]&map[i]) continue; ///第二行与图无效
                for(int k=0; k<a; k++)
                {
                    if(stk[k]&map[i-1]||stk[j]&stk[k]) continue;  /// 第一行与图无效  或  第二行与第一行无效
                    dp[i][j]=(dp[i][j]+dp[i-1][k])%100000000;  /// 上一行的 K 状态对于这行有效 加上上一行 K状态  下求得的个数
                }
            }
        }
        long long ans=0;
        for(int i=0;i<a;i++)
        {
            ans=(ans+dp[m][i])%100000000;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值