1001

Problem Description

I have a very simple problem for you. Given two integers A and B, your jobis to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) whichmeans the number of test cases. Then T lines follow, each line consists of twopositive integers, A and B. Notice that the integers are very large, that meansyou should not process them by using 32-bit integer. You may assume the lengthof each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is"Case #:", # means the number of the test case. The second line isthe an equation "A + B = Sum", Sum means the result of A + B. Notethere are some spaces int the equation. Output a blank line between two testcases.

Sample Input

2

1 2

112233445566778899998877665544332211

Sample Output

Case 1:

1 + 2 = 3

 

Case 2:

112233445566778899 +998877665544332211 = 1111111111111111110

 

 

 

#include<iostream>

using namespace std;

#include<string>

int strlen(string str)

{

    int a=0;

   while(str[a++]);

    return a-2;

}

int main()

{

    intn,m,a,s1,s2,x,y;

    char str[10];

    stringstr1,str2,str3;

    cin>>n;

    gets(str);

   for(a=1;a<=n;a++)

    {

       cin>>str1>>str2;

        m=0;

       str3="";

       x=strlen(str1);y=strlen(str2);

       while(x>=0||y>=0)

        {

            s1=0;

           if(x>=0) s1+=str1[x]-48;

            if(y>=0) s1+=str2[y]-48;

            str3+=(s1+m)%10+48;

            m=(s1+m)/10;

             x--;y--;

        }

        if(m>0)str3+=m+48;

       s2=strlen(str3);

       cout<<"Case "<<a<<":"<<endl;

       cout<<str1<<" + "<<str2<<" =";

       while(s2>=0) cout<<str3[s2--];

       cout<<endl;

        if(a!=n)cout<<endl;

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值