统计难题

统计难题

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131070/65535K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 5
Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 注意:本题只有一组测试数据,处理到文件结束.
 
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 
Sample Input
  
  
banana band bee absolute acm ba b band abc
 
Sample Output
  
  
2 3 1 0
查找字典树,字典树的根节点是空的,字典树的创建
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct node
{
    int n;
    struct node *next[26];
} node ,*Node;
Node root;
void insert(char *str)
{
    /*插入是插入到当前节点的下一节点,
    故先判断当前节点的子节点是否为空来判断此字母是否在此字典树中*/
    int len=strlen(str);
    int i,index;
    Node now=NULL;
    Node child=NULL;
    now=root;
    if(len==0)
        return ;
    for(i=0;i<len;i++)
    {

        index=str[i]-'a';
        if(now->next[index]!=NULL)
        {

            now=now->next[index];
            (now->n)++;
        }
        //创建新节点;
        else
        {
            child=(Node)calloc(1,sizeof(node));
            now->next[index]=child;
            now=child;
            (now->n)=1;
        }
    }
}
int find(char *str)
{
    struct node *now=root;
    int i,len=strlen(str),index;
    for(i=0;i<len;i++)
    {
        index=str[i]-'a';
        if(now->next[index]==NULL)
            return 0; //还没匹配完表示此字典树中没有此单词;
        else
            now=now->next[index];
    }
    return now->n;
}
//释放内存,但貌似没多大用;
void release(Node root)
{
    int i;

    if (NULL == root)
    {
        return;
    }

    for (i = 0; i < 26; i++)
    {
        if ( root->next[i] != NULL )
        {
            release( root->next[i] );
        }
    }

    free( root );
    root = NULL;
}
int main()
{
    char str[11];
    root=(Node)calloc(1,sizeof(node));

    while(gets(str) , strcmp(str,"")!=0)
    {
        insert(str);
    }

    while(scanf("%s",str)!=EOF)
    {
        int i=find(str);
        printf("%d\n",i);
    }
    release(root);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值