Battle City

Battle City

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Problem Description
Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
 

Input
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
 

Sample Input
  
  
3 4 YBEB EERE SSTE 0 0
 

Sample Output
  
  
8
题意:寻找最短路径
此题可以用优先队列+广搜解决;首先得知道优先队列的定义和使用;
#include <iostream>
#include <queue>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
int dir[4][2]= {{0, 1}, {0, -1}, {1, 0}, {-1, 0}},a,b,visit[305][305];
char map[305][305];
typedef struct tank
{
    int x,y,cost;
};
bool operator < (const tank &p,const tank &q)
{
    return p.cost > q.cost;
}
int judge(int i,int j)
{
    if(i < 0 || j < 0 || i >= a || j >= b||map[i][j] == 'R' || map[i][j] == 'S' || visit[i][j]==1)
        return 1;
    return 0;
}

int bfs(int p,int q)
{
    int m,n,i;
    priority_queue <tank> que;
    tank in,out;
    in.x=p;
    in.y=q;
    in.cost=0;
    que.push(in);
    while(!que.empty())
    {
        out=que.top();
        que.pop();
        if(map[out.x][out.y]=='T')
        {
            printf("%d\n",out.cost);
            return 1;
        }
        for(i=0; i<4; i++)
        {
            m=out.x+dir[i][0];
            n=out.y+dir[i][1];
            if(!judge(m,n))
            {
                visit[m][n]=1;
                in.x=m;
                in.y=n;
                in.cost=out.cost+1;
                if(map[m][n]=='B')
                    in.cost++;
                que.push(in);
            }
        }
    }
    return 0;
}
int main()
{
    int i,j;
    while(scanf("%d %d",&a,&b)&&(a+b))
    {
        getchar();
        memset(visit,0,sizeof(visit));
        for(i=0; i<a; i++)
        {
            for(j=0; j<b; j++)
                scanf("%c",&map[i][j]);
            getchar();
        }
        for(i=0; i<a; i++)
        {
            for(j=0; j<b; j++)
            {
                if(map[i][j]=='Y')
                {
                    visit[i][j]=1;
                    if(!bfs(i,j))
                        printf("-1\n");
                    break;
                }
            }
        }
    }
    return 0;
}


前言: 作者系四川大学计算机科学系毕业,但是毕业后十几年都没有编过程序,干的工作有抄水电表,网管,销售工作,最近发现人渐渐老去,有心愿未了,于是最近跟着网络视频教学,学习了一下VC++和面向对象编程,就自已小时候最爱玩的坦克大战为练习,来熟悉和巩固对VC++的学习。 本作特点: 1. 可能是世界上最接近“坦克大战”原作的VC程序. 几乎99%相似模拟度。 2. 本作还特别包括“坦克90”加强版。 3. 即时存档,读档功能。 4. 即时回退,时光倒流功能。 5. 播放战斗录相功能。 6. 智能躲避敌方攻击的功能。(在演示状态) 7. 敌方坦克智能躲避工方攻击的功能。(在TANKE90模式) 8. 对Win7兼容性不好, 运行会变慢 9. 本作是精确到象素级的模拟原作了. 如何编译: 1. 运行VC6. 2. 用打开工作空间的方式, 打开Tank.dsw 3. 如编译出现Diretx方面的错,请下载directx8程序包http://115.com/file/clqzomlm#dx81sdk.zip 加入到你的VC6里面, 如何安装请查网上. 4. 根目录下有Tank.exe已经编译好的了, 你可以试一试, 360可能会误报, 但保证没有病毒. 不信你自已编译好后, 也可能会误报 后记: 本次放出的是DirectX版本, 如有其它问题请联系作者. 作者邮箱: romman@163.com 另外,还有一个CFrame版本,和一个WIN32版本,这两个版本效率不高,但兼容性好,有需要的联系。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值