http://acm.hdu.edu.cn/showproblem.php?pid=1010
Tempter of the Bone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 69524 Accepted Submission(s): 19117
Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed.
'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed.
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
Sample Output
NO YES
01图剪枝提高程序运行效率;
#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <stdlib.h>
using namespace std;
char mp[10][10];
int mark[10][10];
int m,n,step;
int firstx,firsty,lastx,lasty;
int dir[4][2]= {0,1,1,0,0,-1,-1,0};
int cut[10][10];
typedef struct node
{
int x,y,step;
};
int judge(int x,int y)
{
if(x<0||y<0||x>=m||y>=n)
return 0;
if(mark[x][y]==1 || mp[x][y]=='X')
return 0;
return 1;
}
int dfs(int row,int col,int sum)
{
mark[row][col]=1; //不可能再经过起点
//printf("x= %d , y = %d , step = %d\n",row,col,sum);
if(mp[row][col]=='D' )
{
if(sum==step)
return 1;
else
return 0;
} //如果到达终点,但步数不对,则返回false
for(int i = 0; i < 4 ; i++)
{
int x = row + dir[i][0];
int y = col + dir[i][1];
if(judge(x,y))
{
mark[x][y] = 1;
if(dfs(x,y,sum+1))
return 1;
mark[x][y] = 0;
}
}
return 0;
}
/*
..X.
..X.
.SDX
..X.
*/
int main()
{
while(scanf("%d %d %d",&m,&n,&step) && (m || n || step))
{
memset(mark,0,sizeof(mark));
getchar();
int i,j;
for(i=0; i<m; i++)
{
scanf("%s",mp[i]);
for(j=0; j<n; j++)
{
if((i+j)%2==0)
cut[i][j] = 0;
else
cut[i][j] = 1;
if(mp[i][j]=='S')
firstx = i,firsty = j;
if(mp[i][j]=='D')
lastx = i, lasty = j;
}
}
if((cut[firstx][firsty]+cut[lastx][lasty])%2 != (step%2)) //01图剪枝
{
printf("NO\n");
continue;
}
int flag = dfs(firstx,firsty,0);
if(flag)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
//http://acm.hdu.edu.cn/showproblem.php?pid=1010