题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1019
Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 30988 Accepted Submission(s): 11726
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
Sample Output
105 10296
求多个数的最小公倍数
最小公倍数=两个数相乘除以最大公约数;
为了防止溢出,先除再乘
#include <iostream>
#include <cstdio>
using namespace std;
int gcd(int a,int b)
{
if(a%b==0)
return b;
return gcd(b,a%b);
}
int main()
{
int n;
scanf("%d",&n);
int a[100000];
while(n--)
{
int m;
scanf("%d",&m);
for(int i=0;i<m;i++)
{
scanf("%d",&a[i]);
}
int temp = a[0];
for(int i=1;i<m;i++)
{
temp = temp/gcd(temp,a[i])*a[i];
}
printf("%d\n",temp);
}
return 0;
}