POJ1201 Intervals(查分约束系统)

题目链接:http://poj.org/problem?id=1201

Intervals
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21873 Accepted: 8244

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

第一次接触查分约束系统


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define M 50005

using namespace std;
int n;
struct Edge
{
    int to,w,next;
}edge[M*3];
int headlist[M];
int d[M];
int vis[M];
int top;
int Left,Right;
void add(int a,int b,int c)
{
    edge[top].to=b;edge[top].w=c;edge[top].next=headlist[a];headlist[a]=top++;
}
void spfa(int s)
{
    memset(vis,0,sizeof(vis));
    for(int i=Left;i<=Right;i++)
        d[i]=-M;
    queue <int> qu;
    d[s]=0;
    qu.push(s);
    vis[s]=0;
    while(!qu.empty())
    {
        int out = qu.front();
        qu.pop();
        vis[out]=0;

        for(int v = headlist[out];v!=-1;v=edge[v].next)
        {
            int y = edge[v].to;

            if(d[y] < d[out]+edge[v].w)
            {
                d[y]=d[out]+edge[v].w;
                if(!vis[y])
                {
                    qu.push(y);
                    vis[y]=1;
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        int a,b,c;
        top=0;
        memset(headlist,-1,sizeof(headlist));
        Left=M;
        Right=-M;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            Left=min(a,Left);
            Right=max(b+1,Right);
            add(a,b+1,c);
        }
        for(int i=Left;i<Right;i++)
        {
            add(i,i+1,0);
            add(i+1,i,-1);
        }
        spfa(Left);
        printf("%d\n",d[Right]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值