1006题解

Problem Description

 Famous Harry Potter,who seemd to be a normal and poor boy,is actually a wizard.Everything changed when he had his birthday of ten years old.A huge man called 'Hagrid' found Harry and lead him to a new world full of magic power. If you've read this story,you probably know that Harry's parents had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the bank hold up by Goblins). And they stepped into the room which stored the fortune from his father.Harry was astonishing ,coz there were piles of gold coins. The way of packing these coins by Goblins was really special.Only one coin was on the top,and three coins consisted an triangle were on the next lower layer.The third layer has six coins which were also consisted an triangle,and so on.On the ith layer there was an triangle have i coins each edge(totally i*(i+1)/2).The whole heap seemed just like a pyramid.Goblin still knew the total num of the layers,so it's up you to help Harry to figure out the sum of all the coins.

 Input

 The input will consist of some cases,each case takes a line with only one integer N(0<N<2^31).It ends with a single 0.

 Output

对于每个输入的N,输出一行,采用科学记数法来计算金币的总数(保留三位有效数字)

Sample Input

1 3 0

Sample Output

1.00E0 1.00E1

 Hint Hint when N=1 ,There is 1 gold coins. when N=3 ,There is 1+3+6=10 gold coins. Source Gardon-DYGG

 #include<stdio.h>
#include<cmath>
int main()
{
   __int64 sum,total;
   double n,p;
    while(scanf("%I64d",&sum)!=EOF&&sum)
    {
  n=log10(1.0*sum/6)+log10(1.0*(sum+1))+log10(1.0*(sum+2));
  total=(int)(n);
        printf("%.2fE%d\n",pow(10.0,n-total),total);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值