HDU 4004 The Frog's Games 二分+贪心

The Frog's Games

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 3272    Accepted Submission(s): 1600

 

 

 

Problem Description

 

 

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

 

Input

 

The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

 

Output

 

For each case, output a integer standing for the frog's ability at least they should have.
 

 

Sample Input

 

 
6 1 2 2 25 3 3 11 2 18
 

 

Sample Output

 

 
4 11
 
 
 
题意及思路: 在青蛙的世界里有一项竞赛,要求青蛙在给定的跳跃次数M 以内跳过河。我们预先知道河宽L,河上有N块石头,青蛙可以在石头上停留。求青蛙的每次跳跃至少跳多远才能顺利过河。
当青蛙跳长等于河宽L时它一定能跳过河。那么通过二分跳长,求出能过河的最短跳长。
 
 
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;

int L, n, m;
int stone[500005];

bool success ( int jump )  /* 判断一个跳长是否能让青蛙顺利过河 */
{
    if ( jump * m < L )
        return false;

    int i = 1, j = 0, cnt = 0;
    while ( i <= n + 1 )
    {
        cnt++;
        if ( jump < stone[i] - stone[j] ) 
            return false;
        while ( jump >= stone[i] - stone[j] && i <= n+1 )
         i++;
        j = i - 1; /* 因为前一跳最远能跳到 i - 1 个石头上, 那么就把这块最远的石头作为下一跳的起点 */
    }
    if ( cnt > m )
        return false;
    return true;
}

int main()
{
    int l, r, mid;
    while ( scanf("%d%d%d",&L,&n,&m) != EOF )
    {
        stone[0] = 0; /* 把起始的河岸看做stone[0],终点河岸看做stone[n+1] */
        stone[n+1] = L;
        for ( int i = 1; i <= n; i++ )
            scanf("%d",stone+i);

        sort(stone+1,stone+1+n);

        l = 0; r = L;
        while ( l <= r )
        {
            mid = ( l + r ) / 2;
            if ( success ( mid ) ) /* 若能顺利过河,那么尝试找一个更短的跳长,看能不能符合要求,否则找一个更大的跳长 */
                r = mid - 1;
            else
                l = mid + 1;
        }
        printf("%d\n",l);
    }
    return 0;
}

 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值