HDU-1088Write a simple HTML Browser

Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.
 

Output
You should display the the resulting text using this rules:
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
  . If you read a <br> in the input, start a new line.
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).
The last line is ended by a newline character.
 

Sample Input
  
  
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. <br> Zwei <br> <br> produzieren zwei Newlines. Es gibt auch noch das tag <hr> was einen Trenner darstellt. Zwei <hr> <hr> produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 

Sample Output
  
  
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. Zwei produzieren zwei Newlines. Es gibt auch noch das tag -------------------------------------------------------------------------------- was einen Trenner darstellt. Zwei -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
  代码;
#include<stdio.h>
#include<string.h>
int main()
{
     int i,flag,num;
     char str[100];
     num=0;
     flag=0;//状态变量
 
 while(scanf("%s",str)!=-1)
 {
  
       if(strcmp(str,"<br>")==0)
	   {
          printf("\n");
          num=0;
          flag=0;
	   }
       else if(strcmp(str,"<hr>")==0)
	   {
        if(flag!=0)
         printf("\n");
        for(i=1;i<=80;i++)
         printf("-");
         printf("\n");
         flag=0;
         num=0;
	   }
       else if(flag==0)
	   {
         printf("%s",str);
         flag=1;
         num+=strlen(str);
	   }
         else
		 {
            num+=strlen(str)+1;
            if(num>80)
			{
               printf("\n");
               num=strlen(str);
               printf("%s",str);
			}
        else
            printf(" %s",str);
		 }
 }
        if(flag!=0)
	     printf("\n");
         return 0;
}
思路解析:
题意 :输入1串字符  每行最多80个,每个单词都是连续的,不连续的不算一个单词 即不给空格 tab 等分开的字符  一个单词中不包含<  >  包含其他符号
遇到 <br> 则输出空格
遇到<hr>  则换到下一行 然后输出80个-  然后再换一行 注意 如果是已经在一个新的一行了 就不用再换到下一行后再输出80个‘-’ 就可以直接输出
输出的时候 每行最多有80个字符   每个单词之间有1个空格
用到了比较字符串函数strcmp()...
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值