hdu 1992 Tiling a Grid With Dominoes

Problem Description

We wish to tile a grid 4 units high and N units long with rectangles (dominoes) 2 units by one unit (in either orientation). For example, the figure shows the five different ways that a grid 4 units high and 2 units wide may be tiled.



Write a program that takes as input the width, W, of the grid and outputs the number of different ways to tile a 4-by-W grid.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset contains a single decimal integer, the width, W, of the grid for this problem instance.

Output

For each problem instance, there is one line of output: The problem instance number as a decimal integer (start counting at one), a single space and the number of tilings of a 4-by-W grid. The values of W will be chosen so the count will fit in a 32-bit integer.

Sample Input

3
2
3
7

Sample Output

1 5
2 11
3 781

#include <cstdlib>
#include <iostream>
using namespace std;
long long dp[1010];
int main(int argc, char *argv[])
{
    dp[0]=1;
    dp[1]=1;
    dp[2]=5;
    dp[3]=11;
    for(int i=4;i<=1000;i++)
     {
         dp[i]=dp[i-1]+4*dp[i-2];
         for(int j=3;j<=i;j++)
          if(j&1) dp[i]+=2*dp[i-j];
          else dp[i]+=3*dp[i-j];
     }
	int n,cas=1,ca;
    cin>>ca;
    while(ca--)
    {
       cin>>n;    
       cout<<cas++<<" "<<dp[n]<<endl;             
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值