poj 1753

Flip Game
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 30088
Accepted: 13052

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
给一张图,找出棋子全变为白或黑所需翻动的最少次数,一次选一个棋子翻转,它周围的四个棋子跟着翻转。
用深搜每个点试一遍。任何数与一异或可翻转。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 1000
char g[5][5];
int map[6][6],ans;
int a[4][2]={1,0,0,1,-1,0,0,-1};
bool ok()
{
    int sum=0;
    for(int i=1;i<=4;i++)
    {
        for(int j=1;j<=4;j++)
        sum+=map[i][j];
    }
    if(sum==16||sum==0)
    return 1;
    else
    return 0;
}
void flip(int x,int y)
{
    for(int i=0;i<4;i++)
        map[x+a[i][0]][y+a[i][1]]^=1;
    map[x][y]^=1;
}
void dfs(int x,int y,int st)
{
    if(ok())
    {
        ans=min(ans,st);
        return ;
    }
    int nx=x,ny=y+1;
    if(ny>4)
    {
        nx++;
        ny=1;
    }
    if(nx>4)
    return ;
    flip(nx,ny);
    dfs(nx,ny,st+1);
    flip(nx,ny);
    dfs(nx,ny,st);
}
int main()
{
    int i,j;
    for(i=0;i<4;i++)
    scanf("%s",g[i]);
    for(i=0;i<4;i++)
        for(j=0;j<4;j++)
        {
            map[i+1][j+1]=g[i][j]=='b'?1:0;
        }
    ans=inf;
    dfs(1,0,0);
    if(ans==inf)
    printf("Impossible\n");
    else
    printf("%d\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值