poj 3190 Stall Reservations

Language:
Stall Reservations
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 2841
Accepted: 1015
Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4
贪心,优先队列,先对开始时间排序,队列中结束时间在前的优先。如果出队元素结束时间比另一元素早则该元素
入队,否则牛棚数加一再入队最早开始的。用一个数组记录顺序
#include<cstdio>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
struct node
{
    int x,y,c;
    friend bool operator<(node a,node b)//一定要加friend,从小到大排序
    {
        return a.y>b.y;
    }
}p[50005];
bool cmp(node a,node b)
{
    return a.x<b.x;
}
int t[50005];
int main()
{
    int i,j,n;
   scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
            p[i].c=i;
        }
        int r=0;
        sort(p,p+n,cmp);
        priority_queue<node>q;
        q.push(p[0]);
        t[p[0].c]=++r;
        for(i=1;i<n;i++)
        {
            node g=q.top();
            if(g.y<p[i].x)
            {
                t[p[i].c]=t[g.c];
                q.pop();
                q.push(p[i]);
            }
            else
            {
                t[p[i].c]=++r;
                q.push(p[i]);
            }
        }
        printf("%d\n",r);
    for(int i=0;i<n;i++)
        printf("%d\n",t[i]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值