The Accomodation of Students

L - The Accomodation of Students
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other. 

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room. 

Calculate the maximum number of pairs that can be arranged into these double rooms. 
 
Input
For each data set: 
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs. 

Proceed to the end of file. 

 
Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms. 
 
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
 
Sample Output
No
3
 




#include <stdio.h>
#include <string.h>
#define Max 201
int maz[Max][Max], match[Max], used[Max], n, m, color[Max],col;
bool flag;
void ranse(int v, int col)//染色法 判断是不是二分 
{
	for(int i = 1; i <= n; i++)
	{
		if(maz[v][i])
		{
			if(!color[i])
			{
				color[i] = -col;
				ranse(i, color[i]);
			}
			else if(color[i] == col)//这点颜色与下一点颜色相同,说明不是最大匹配 
			{
				flag = false;
				return; 
			}
			if(flag == false)
				return;	
		}
	}
}
int dfs(int v)
{
	for(int i = 1; i <= n; i++)
	{
		if(maz[v][i] && !used[i])
		{
			used[i] = 1;
			if(match[i] == -1 || dfs(match[i]))
			{
				match[i] = v;
				return 1;
			}
		}
	}
	return 0;
}
int check()
{
	flag = true;
	color[1] = 1;//颜色1代表黑色,-1代表白色
	ranse(1, 1);
	return flag;
}
int matching()
{
	int res = 0;
	memset(match , -1, sizeof(match));
	for(int i = 1; i <= n; i++){
		memset(used, 0, sizeof(used));
		if(dfs(i))
			res++;
	}
	return res;
}
int main()
{
	int i, j, k, a, b, num;
	while(~scanf("%d %d",&n, &m))
	{
		memset(maz, 0, sizeof(maz));
		memset(color, 0, sizeof(color));
		for(i = 0; i < m; i++)
		{
			scanf("%d %d",&a, &b);
			maz[a][b] = 1;
		}
		if(!check())
		{
			printf("No\n");
			continue;
		}
		num = matching();
		printf("%d\n",num);
	}
	return 0; 
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值