HDU—1021—Fibonacci Again—【入门题】

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36573    Accepted Submission(s): 17660


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 



做ACM,英语很重要。。。 “3 divide evenly” 就是能被3整除的意思。。。

题意:新定义了一个斐波那契数列,输入n,

如果F(n)能被3整除,输出“yes”,否则输出“no”

数据量:1000000,不能打表,否则果断溢出。。。想想还是找找看规律。。。


F(0)     F(1)     F(2)     F(3)     F(4)     F(5)     F(6)     F(7)     F(8)     F(9)     F(10)     F(11)      F(12)     F(13)     F(14)     F(15)

7         11        18        29        47        76       123      199      322      521      843        1364       2207      3571      5778      9349

no       no        yes       no        no        no       yes       no        no        no       yes         no          no          no          yes        no


所以当 n=2+4*k 【k=0,1,2,……】时,输出“yes”


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if((n-2)%4==0)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值