POJ—3070—Fibonacci—【矩阵快速幂】

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9396 Accepted: 6668

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source



个赛有做过。。。用最朴素的方法,霸王硬上弓,结果超时了。。。。。。

后来听说是矩阵快速幂,那是完全不晓得什么是矩阵快速幂,后来隔了很久才学了一下。。。今天再来做这道题,1A,0Ms,感动哭了。。。

学过矩阵快速幂后写了一个专题,自转,发个链接:

http://blog.csdn.net/u013795055/article/details/38599321

解题思路其实就是学一下什么是矩阵快速幂,感觉是模板题。。。

【大神说:怎么还在做这道水题。。。o(╯□╰)o。。。给大神跪了】

直接上代码,感觉写的冗长了。。。可以优化的。。。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;
#define LL __int64
#define MOD 10000

typedef struct MATRIX   //定义一个矩阵结构体
{
    int mat[2][2];
}MATRIX;

MATRIX mat_multiply(MATRIX a,MATRIX b)  //矩阵乘法
{
    MATRIX c;
    memset(c.mat,0,sizeof(c.mat));

    for(int k=0;k<2;k++)
        for(int i=0;i<2;i++)
            if(a.mat[i][k])     //剪枝
                for(int j=0;j<2;j++)
                    if(b.mat[k][j]) //再剪枝,可以看上面的连接,完全一样的。。。
                    {
                        c.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
                        if(c.mat[i][j]>=MOD)
                            c.mat[i][j]%=MOD;   //取模
                    }
    return c;
}

MATRIX mat_quick_index (MATRIX a,int N)
{
    MATRIX E;
    for(int i=0;i<2;i++)    //学到的单位矩阵的酷炫炸天的初始化方法
        for(int j=0;j<2;j++)
            E.mat[i][j]=(i==j);
    while(N)            //快速幂的核心
    {
        if(N &1)        //与运算,判断奇偶很有用的
            E=mat_multiply(E,a);
        N>>=1;          //位运算,向右是除以2,向左是乘以2,这个快!
        a=mat_multiply(a,a);
    }
    return E;
}

int main()
{
    MATRIX a,b;
    int N;
    while(scanf("%d",&N)!=EOF)
    {
        if(N==-1)
            break;
        a.mat[0][0]=a.mat[0][1]=a.mat[1][0]=1;
        a.mat[1][1]=0;
        b=mat_quick_index(a,N);
        printf("%d\n",b.mat[0][1]);
    }

    return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值