ZOJ Problem Set - 1858 Soundex

Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding. 

Soundex coding involves translating each word into a series of digits in which each digit represents a letter:

1 represents B, F, P, or V
2 represents C, G, J, K, Q, S, X, or Z
3 represents D or T
4 represents L
5 represents M or N
6 represents R

The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with the same Soundex coding are considered equivalent.


Input

Each line of input contains a single word, all upper case, less than 20 letters long.


Output

For each line of input, produce a line of output giving the Soundex code.


Sample Input

KHAWN
PFISTER
BOBBY


Sample Output

25
1236
11

#include <cstdio>
#include <cstring>

using namespace std;

int main(void){
    char change[27]="*123*12**22455*12623*1*2*2";
    char input[21];
    int i;
    while(scanf("%s",input)!=EOF){
        int len;
        char temp,prev='0';
        len=strlen(input);
        for(i=0;i<len;i++){
            temp=change[input[i]-'A'];
            if(temp=='*'){
                prev='0';
                continue;
            }
            if(temp==prev) continue;
            printf("%c",temp);
            prev=temp;
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值