POJ Sliding Window

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题解

这题题目的意思看看就懂了,所以就不翻译了。
虽然我把它归到dp中,但是只是一题 比较裸的单调队列。
可以开两个队列来保存结果,一个单调递增来保存最小值,一个单调递减来保存最大值,每个元素入队列时都给一个入队编号,然后我们在判断的时候,只要判断当前元素的序号与队首元素的序号相差不大与K,则最值就是当前队首元素,否则,队首指针向后移动,直到找到一个符合条件的元素。
为什么poj上是用c++跑的至少都有4000ms
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
using namespace std;
int n,k,len,a[1000002],m=0;
int t1,t2,w1,w2,ans1[1000002],ans2[1000002];
struct dui
{int x,w;} f1[1000002],f2[1000002];
void doit(int s,int w)
{
	while(t1<=w1&&s<=f1[w1].x) w1--;
	f1[++w1].x=s; f1[w1].w=w;
	while(t2<=w2&&s>=f2[w2].x) w2--;
	f2[++w2].x=s; f2[w2].w=w;
	if(w-len==0)
	   {while(t1<=w1&&w-f1[t1].w>=k) t1++;
	    ans1[m+1]=f1[t1].x; 
	    while(t2<=w2&&w-f2[t2].w>=k) t2++;
	    ans2[m+1]=f2[t2].x;
	    len++; m++;
	   }
}
int main()
{
	scanf("%d%d",&n,&k); len=k;
	for(int i=1;i<=n;i++) scanf("%d",&a[i]);
	t1=w1=t2=w2=1;
	f1[t1].x=0x7fffffff;
	for(int i=1;i<=n;i++)
	   doit(a[i],i);
	int kg=0;
	for(int i=1;i<=m;i++)
	   {if(kg==1) printf(" ");
	    printf("%d",ans1[i]); kg=1;
	   }
	printf("\n"); kg=0;
	for(int i=1;i<=m;i++)
	   {if(kg==1) printf(" ");
	    printf("%d",ans2[i]); kg=1;
	   }
	return 0;   
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值