POJ Nim (2975)

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101
 

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1= 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

题目大意

Nim游戏,给定n堆石子,“你”为先手,如果你必输,输出0,否则输出一个方案数,表明总共有多少总策略可以保证自己必胜。
输入有多组数据,第一行为n( 1 ≤ n ≤ 1000),表示有n堆石子。第二行有n个数表示刚开始时各个堆的石子数。
输入以n=0结束。

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0

题解

对于一个状态,要是它是先手必胜的,就一定满足从这个状态可以一步转成“先手必输”的状态。也就是说,我们要从n堆石子中的一堆取走一些石子,使剩下的石子数异或等于0.

我们可以从原石子堆中任选一堆,设其石子数为m。将剩下的石子异或起来,得到一个数x,只要x<m,就是一种必胜策略。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
using namespace std;
int n,a[1002],ans;
void doit()
{
	int s,count=0;
	for(int i=1;i<=n;i++)
	   {s=ans^a[i];
	    if(s<a[i]) count++;
	   }
	printf("%d\n",count);
}
int main()
{
	while(scanf("%d",&n)&&n)
	   {ans=0;
		for(int i=1;i<=n;i++)
	       {scanf("%d",&a[i]);
		    ans=ans^a[i];
		   }
		if(ans==0) printf("0\n");
		else doit();
	   }
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值