POJ A Chess Game

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

题目大意

给出一个无环有向图,在节点上放几个棋子,两个人往有向路径移动,最后没的移动的输。

输入有多组测试数据。

第一行为n(1 <= n <= 1000) ,表示有n个节点(节点编号为0~n)。接下来n行,第一个数字xi表示第i各节点可到达的节点数量,接下来xi个数。

接下来有一些询问,第一个数m(1 <= m <= 10), 表示有m个棋子。接下来有m个数,表示棋子所在的节点。询问以m=0结束。

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input

4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output

WIN
WIN
WIN
LOSE
WIN

Hint

Huge input,scanf is recommended.
 

题解

基本的sg函数题。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<cmath>
using namespace std;
int n,m,zz,ans,sg[1002],head[1002];
struct bian
{int to,nx;} e[1000002];
void insert(int x,int y)
{zz++; e[zz].to=y; e[zz].nx=head[x]; head[x]=zz;}
int dfs(int x)
{
	if(sg[x]!=-1) return sg[x];
	bool pd[1002]={0};
	int i=head[x];
	while(i!=-1)
	   {pd[dfs(e[i].to)]=1;
	    i=e[i].nx;
	   }
	for(int i=0;;i++)
	   {if(!pd[i]) return sg[x]=i;}
}
int main()
{
    while(scanf("%d",&n)!=EOF)
       {memset(sg,-1,sizeof(sg));
        memset(head,-1,sizeof(head));
        zz=0;
		for(int i=0;i<n;i++)
	       {scanf("%d",&m);
		    if(m==0) sg[i]=0;
		    else
		       {for(int j=0;j<m;j++)
			       {int a;
					scanf("%d",&a); insert(i,a);
				   }
			   }
		   } 
	    while(scanf("%d",&m)&&m)
		   {int a; ans=0;
		    for(int i=1;i<=m;i++)
			   {scanf("%d",&a);
		        ans^=dfs(a);
			   }
			if(ans) printf("WIN\n");
		    else printf("LOSE\n");
		   }
	   }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值