poj-2425 A Chess Game (SG函数模板)

题目链接:https://cn.vjudge.net/problem/POJ-2425
Let’s design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me… I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output

There is one line for each query, which contains a string “WIN” or “LOSE”. “WIN” means that the player taking the first turn can win the game according to a clever strategy; otherwise “LOSE” should be printed.

Sample Input
4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output
WIN
WIN
WIN
LOSE
WIN

Hint

Huge input,scanf is recommended.

题目大意:就是nim游戏的有向图形式,输入一个n,接下来n行表示0-n-1为起点的有向边,每行的第一个数表示与起点相连的终点个数,之后是各个终点。构建有向图完成。
接下来就要在有向图的顶点上放棋子。有一系列的询问,询问以m开头,表示有m个棋子,之后m个数是棋子所在的顶点编号。两人轮流沿着有向边移动棋子,最终不能移动棋子的输。m为0结束询问。

注意点:1、记忆化搜索否则超时。
2、标记数组并不是全局共享的,而是每一个点都有一个标记数组,是局部变量。

#include<cstdio>
#include<cstring> 
#include<vector>
#include<algorithm>
using namespace std;
vector<int> G[1005];
int sg[1005];
int n,m,x;
void init(){   //初始化 
 memset(sg,-1,sizeof(sg));
 for(int i=0;i<n;i++)
 G[i].clear();
}
int getSG(int x){   //SG函数 
 if(sg[x]!=-1) return sg[x];
 if(G[x].size()==0) return sg[x]=0;
 bool book[1005];   //这个标记数组是局部的,只能放在函数里,不能放在全局
 memset(book,0,sizeof(book));
 for(int i=0;i<G[x].size();i++){
  sg[G[x][i]]=getSG(G[x][i]);
  book[sg[G[x][i]]]=true;
 }
 for(int i=0;;i++){
  if(!book[i]) return sg[x]=i;
 }
}
int main(){
 while(~scanf("%d",&n)){
  init();
  for(int i=0;i<n;i++){
   scanf("%d",&m);
   while(m--){
    scanf("%d",&x);
    G[i].push_back(x);
   }
  }
  while(scanf("%d",&m)&&m){
   int k=0;
   while(m--){
    scanf("%d",&x);
    k^=getSG(x);
   }
   if(k==0) printf("LOSE\n");
   else printf("WIN\n");
  }
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值