1000. 用指针方法处理数的排序

Description

输入3个整数,按从大到小的书序输出。

Input

12 8 23

Output

23 12 8

Sample Input
 Copy sample input to clipboard
10 8 9
Sample Output
10 9 8

Problem Source: 指针

#include<iostream>

using namespace std;
int c[4];
int sort(int *p)
{
 int *a,*b,temp;
 for(a=p;a<p+3;a++)
  for(b=a+1;b<p+3;b++)
   if(*a<=*b)
   {
    temp=*a;
    *a=*b;
    *b=temp;
   }
 for(a=p;a<p+3;a++) cout<<*a<<" ";
}
int main()
{
 for(int i=0;i<3;i++)
 { cin>>c[i];
 }
 sort(c);

 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值