题目:
CRB and Candies
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 652 Accepted Submission(s): 324
Problem Description
CRB has
N
different candies. He is going to eat
K
candies.
He wonders how many combinations he can select.
Can you answer his question for all K (0 ≤ K ≤ N )?
CRB is too hungry to check all of your answers one by one, so he only asks least common multiple(LCM) of all answers.
He wonders how many combinations he can select.
Can you answer his question for all K (0 ≤ K ≤ N )?
CRB is too hungry to check all of your answers one by one, so he only asks least common multiple(LCM) of all answers.
Input
There are multiple test cases. The first line of input contains an integer
T
, indicating the number of test cases. For each test case there is one line containing a single integer
N
.
1 ≤ T ≤ 300
1 ≤ N ≤ 106
1 ≤ T ≤ 300
1 ≤ N ≤ 106
Output
For each test case, output a single integer – LCM modulo 1000000007(
109+7
).
Sample Input
5 1 2 3 4 5
Sample Output
1 2 3 12 10
Author
KUT(DPRK)
Source
Recommend
wange2014
题意:求出LCM{C(N,0),C(N,1),....,C(N,N)}%1000000007。
思路:打表找出前几项,然后在OEIS上发现LCM{C(N,0)...C(N,N)}=LCM(1,2,3,...,N)/N,所以我们只要求出LCM{1,2,3...,N},然后再除以n即可。算LCM的时候只要找出每个小于N的质数的次数最大值,然后把他们乘起来就可以了。除以n的时候由于要取模,所以变为乘以n对与mod的逆元。
代码:
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include<climits>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <fstream>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <list>
#include <stdexcept>
#include <functional>
#include <utility>
#include <ctime>
using namespace std;
#define PB push_back
#define MP make_pair
#define REP(i,x,n) for(int i=x;i<(n);++i)
#define FOR(i,l,h) for(int i=(l);i<=(h);++i)
#define FORD(i,h,l) for(int i=(h);i>=(l);--i)
#define SZ(X) ((int)(X).size())
#define ALL(X) (X).begin(), (X).end()
#define RI(X) scanf("%d", &(X))
#define RII(X, Y) scanf("%d%d", &(X), &(Y))
#define RIII(X, Y, Z) scanf("%d%d%d", &(X), &(Y), &(Z))
#define DRI(X) int (X); scanf("%d", &X)
#define DRII(X, Y) int X, Y; scanf("%d%d", &X, &Y)
#define DRIII(X, Y, Z) int X, Y, Z; scanf("%d%d%d", &X, &Y, &Z)
#define OI(X) printf("%d",X);
#define RS(X) scanf("%s", (X))
#define MS0(X) memset((X), 0, sizeof((X)))
#define MS1(X) memset((X), -1, sizeof((X)))
#define LEN(X) strlen(X)
#define F first
#define S second
#define Swap(a, b) (a ^= b, b ^= a, a ^= b)
#define Dpoint strcut node{int x,y}
#define cmpd int cmp(const int &a,const int &b){return a>b;}
/*#ifdef HOME
freopen("in.txt","r",stdin);
#endif*/
const int MOD = 1e9+7;
typedef vector<int> VI;
typedef vector<string> VS;
typedef vector<double> VD;
typedef long long LL;
typedef pair<int,int> PII;
//#define HOME
int Scan()
{
int res = 0, ch, flag = 0;
if((ch = getchar()) == '-') //判断正负
flag = 1;
else if(ch >= '0' && ch <= '9') //得到完整的数
res = ch - '0';
while((ch = getchar()) >= '0' && ch <= '9' )
res = res * 10 + ch - '0';
return flag ? -res : res;
}
/*----------------PLEASE-----DO-----NOT-----HACK-----ME--------------------*/
int vis[1000000+5];
int prime[1000000+5];
int cnt;
void getprime()
{
cnt=0;
MS0(vis);
for(int i=2;i<=1000000;i++)
{
if(!vis[i])
prime[cnt++]=i;
for(int j=0;j<cnt&&prime[j]<=1000000/i;j++)
{vis[prime[j]*i]=1;
if(i%prime[j]==0)
break;
}
}
}
long long inv(long long a,long long m)
{
if(a==1)
return 1;
return inv(m%a,m)*(m-m/a)%m;
}
const int mod= 1e9+7;
int main()
{getprime();
int T;
RI(T);
while(T--)
{
int n;
RI(n);
n++;
int ans=1;
for(int i=0;i<cnt&&prime[i]<=n;i++)
{
//int k=(int)(log10(n)/log10(prime[i])+0.5);
int tmp=1;
for(;(long long )tmp*prime[i]<=n;)
tmp=((long long )tmp*prime[i])%mod;
ans=((long long )ans*tmp)%mod;
}
ans=((ans*inv(n,mod))%mod+mod)%mod;
printf("%d\n",ans);
}
return 0;
}