hdu4122 Alice's mooncake shop(单调队列)

题目:

Alice's mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3425    Accepted Submission(s): 868


Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest.

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
 

Input
The input contains no more than 10 test cases.
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens.
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers.
All the orders are sorted by the time in increasing order.
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the i th line( i starts from 1) contains a integer indicating the cost to make a mooncake during the i th hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1 st hour, Jan 1st 2000 1 o'clock belongs to the 2 nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.
 

Output
You should output one line for each test case: the minimum cost.
 

Sample Input
  
  
1 10 Jan 1 2000 9 10 5 2 20 20 20 10 10 8 7 9 5 10 0 0
 

Sample Output
  
  
70
Hint
“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o'clock , there's a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.
 

Source
 

Recommend
lcy
 

题意:有n个订单,每个订单的时间和订月饼的数量都告诉,这家月饼店开了M个小时,每个小时制作一个月饼的成本都变化并且告诉你和储存一个月饼一小时的成本也告诉。一个月饼的保质期为T小时,需要在订单来之前或在订单来的时候把月饼做好,做月饼的时间不计,问最少的成本。

思路:由于储存一个月饼的成本是线性增长的,我们可以枚举这M个小时,用一个递增的单调队列来维护制作一个月饼的成本,如果当前时间制作月饼的成本比以前的低,那么它肯定更优,原因是储存月饼的成本线性增长,但是当前的时间制作月饼更不容易超过保质期,所以他是更优的。在比较当前月饼和之前月饼的制作成本的时候要加上以前的月饼储存到现在所花的钱,这样在以后他们的增长才是公平的。当前时间和某个订单的时间相同的时候,就看队首元素是否超过了保质期,如果没超过就用他作为制作月饼的成本再加上它到现在的存储费用,如果超过了保质期就出队直到找到一个没超过保质期的。

代码:

#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include<climits>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <fstream>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <list>
#include <stdexcept>
#include <functional>
#include <utility>
#include <ctime>
using namespace std;

#define PB push_back
#define MP make_pair

#define REP(i,x,n) for(int i=x;i<(n);++i)
#define FOR(i,l,h) for(int i=(l);i<=(h);++i)
#define FORD(i,h,l) for(int i=(h);i>=(l);--i)
#define SZ(X) ((int)(X).size())
#define ALL(X) (X).begin(), (X).end()
#define RI(X) scanf("%d", &(X))
#define RII(X, Y) scanf("%d%d", &(X), &(Y))
#define RIII(X, Y, Z) scanf("%d%d%d", &(X), &(Y), &(Z))
#define DRI(X) int (X); scanf("%d", &X)
#define DRII(X, Y) int X, Y; scanf("%d%d", &X, &Y)
#define DRIII(X, Y, Z) int X, Y, Z; scanf("%d%d%d", &X, &Y, &Z)
#define OI(X) printf("%d",X);
#define RS(X) scanf("%s", (X))
#define MS0(X) memset((X), 0, sizeof((X)))
#define MS1(X) memset((X), -1, sizeof((X)))
#define LEN(X) strlen(X)
#define F first
#define S second
#define Swap(a, b) (a ^= b, b ^= a, a ^= b)
#define Dpoint  strcut node{int x,y}
#define cmpd int cmp(const int &a,const int &b){return a>b;}

 /*#ifdef HOME
    freopen("in.txt","r",stdin);
    #endif*/
const int MOD = 1e9+7;
typedef vector<int> VI;
typedef vector<string> VS;
typedef vector<double> VD;
typedef long long LL;
typedef pair<int,int> PII;
//#define HOME

int Scan()
{
	int res = 0, ch, flag = 0;

	if((ch = getchar()) == '-')				//判断正负
		flag = 1;

	else if(ch >= '0' && ch <= '9')			//得到完整的数
		res = ch - '0';
	while((ch = getchar()) >= '0' && ch <= '9' )
		res = res * 10 + ch - '0';

	return flag ? -res : res;
}
/*----------------PLEASE-----DO-----NOT-----HACK-----ME--------------------*/


int n,m;
int M[]={0,31,28,31,30,31,30,31,31,30,31,30,31};
bool isrun(int year)
{
    return ((year%4==0)&&(year%100))||(year%400==0);
}
int mon(char *m)
{
    if(strcmp(m,"Jan") == 0)return 1;
    if(strcmp(m,"Feb") == 0)return 2;
    if(strcmp(m,"Mar") == 0)return 3;
    if(strcmp(m,"Apr") == 0)return 4;
    if(strcmp(m,"May") == 0)return 5;
    if(strcmp(m,"Jun") == 0)return 6;
    if(strcmp(m,"Jul") == 0)return 7;
    if(strcmp(m,"Aug") == 0)return 8;
    if(strcmp(m,"Sep") == 0)return 9;
    if(strcmp(m,"Oct") == 0)return 10;
    if(strcmp(m,"Nov") == 0)return 11;
    return 12;
}
int trans(char *month,int date,int year,int h)
{
    int t=0;
    for(int i=2000;i<year;i++)
    {
        if(isrun(i))
            t+=366;
        else
            t+=365;
    }
    int flag=isrun(year);
    int m=mon(month);
    for(int i=1;i<m;i++)
    {
        if(i==2&&flag)
            t+=29;
        else
            t+=M[i];
    }
    t+=date-1;
    t=t*24+h;
    return t;



}
struct order
{
    int num;
    int time;
};
order ord[3000];
order q[100000+5];
int main()
{
while(RII(n,m)!=EOF)
{   if(n==0&&m==0)
break;
    char str[5];
    int d;
    int y;
    int h;
    int r;
    for(int i=0;i<n;i++)
    {
      scanf("%s%d%d%d%d",str,&d,&y,&h,&r);
      ord[i].num=r;
      ord[i].time=trans(str,d,y,h);
    }
    int t,s;
    RII(t,s);
    int front=0;
    int rear=0;
    int p=0;
    long long int ans=0;
    for(int i=0;i<m;i++)
    {   int a;
    RI(a);
        while(front<rear&&q[rear-1].num+(i-q[rear-1].time)*s>=a)
            rear--;
        q[rear].num=a;
        q[rear++].time=i;
        while(p<n&&ord[p].time==i)
        {
            while(q[front].time+t<i)
                front++;
            ans+=(long long )q[front].num*ord[p].num+(long long )(i-q[front].time)*s*ord[p].num;
            p++;
        }
    }
    printf("%I64d\n",ans);

}


        return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值