poj2386

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
dfs 简单题
搜索到一点后,标记周围所有点,记main函数中一共所搜几次,就是池塘数
#include<cstdio>
#include<cstring>
#include<iostream>
#include<stack>
#include<queue>
const int Max=100000;
#define INF 0xfffffff
typedef  long long ll;
using namespace std;
char str[105][105];
bool vis[105][105];
int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
int n,m;
void dfs(int x,int y)
{
 for(int k=0;k<8;k++)
 {
     int tx=x+dir[k][0];
     int ty=y+dir[k][1];
     if(tx >= 0 && tx < n && ty >= 0 && ty < m && str[tx][ty] == 'W' && vis[tx][ty]==false)
     {
         vis[tx][ty]=true;
         dfs(tx,ty);
     }
 }
}
int main()
{
    int i,j;
    int ans=0;
    scanf("%d%d",&n,&m);
    for(i=0;i<n;i++)
        scanf("%s",str[i]);
    for(i=0;i<n;i++)
        for(j=0;j<m;j++)
    {
        if(!vis[i][j]&&str[i][j]=='W')
        {
            vis[i][j]=true;//标记该点,很容易忽略,切记
            dfs(i,j);
            ans++;
        }
    }
    printf("%d\n",ans);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值