hdu 2444 The Accomodation of Students(判二分+最大匹配)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2444

Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
  
  
No 3
 

Source


题意是判断是否是二分图,如果是,求出二分的最大匹配。由于n比较小,所以用匈牙利算法求最大匹配。。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=205;
int mp[maxn][maxn];
int vis[maxn];
int nx,ny;
int cx[maxn],cy[maxn];
int c[maxn];
int n,m;
int bfs(int u)
{
    queue<int>q;
    q.push(u);
    c[u]=0;
    while(!q.empty())
    {
        int t=q.front();
        q.pop();
        for(int i=1;i<=n;i++)
        {
            if(mp[t][i])               //如果有关系,则染成不同色
            {
                if(c[i]==-1)
                    {
                        c[i]=1-c[t];
                        q.push(i);
                    }
                else if(c[i]==c[t])   //如果出现想同色,则不符合二分图
                    return 0;
            }

        }
    }
    return 1;
}
int find(int u)
{
    for(int i=1;i<=n;i++)
    {
        if(mp[u][i]&&!vis[i])   //不在交替路中
        {
            vis[i]=1;
            if(cy[i]==-1||find(cy[i]))   //如果是未匹配点,则交替路为增广路
            {
                cy[i]=u;                 //交换路径,成功找到一条增广路,返回1
                cx[u]=i;
                return 1;
            }
        }
    }
    return 0;      //不存在增广路,返回0
}
void match()
{
    int res=0;
    for(int i=1;i<=n;i++)
        cx[i]=-1;
    for(int j=1;j<=n;j++)
        cy[j]=-1;
    for(int i=1;i<=n;i++)
    {
        if(cx[i]==-1)
        {
            memset(vis,0,sizeof(vis));
            res+=find(i);
        }
    }
    printf("%d\n",res);
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d %d",&n,&m)==2)
    {
        memset(mp,0,sizeof(mp));
        memset(vis,0,sizeof(vis));
        memset(c,-1,sizeof(c));
        while(m--)
        {
            int a,b;
            scanf("%d %d",&a,&b);
            mp[a][b]=1;
        }
        if(bfs(1))
            match();
        else
            printf("No\n");
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值