The Accomodation of Students(二分匹配+二分图判定)

The Accomodation of Students(二分匹配+二分图判定)

There are a group of students. Some of them may know each other, while others don’t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don’t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print “No”. Otherwise, print the maximum number of pairs that can be arranged in those rooms.

Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output
No
3

题意: 给你几组互为朋友的两个人(a,b互为朋友,b,c互为朋友,但a,c不一定互为朋友),问能不能分成两组,每组中的人都互不认识,如果能,求出认识的最多能住几间房(两人一间),否则输出No

思路: 先判断是否能形成二分图,如果能就用二分匹配,求出最大匹配数,如果不能直接输出No

AC代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
const int N=1100;
int book[N],a[N][N],match[N],c[N],n,m;
int judge()//二分图判定
{
	queue<int>q;
	c[1]=1;
	q.push(1);
	while(!q.empty())
	{
		int now=q.front();
		q.pop();
		for(int i=1;i<=n;i++)
		{
			if(now==i)
			continue;
			if(!c[i]&&a[now][i])//如果是朋友且没分组 
			{
				c[i]=-c[now];//分到另一组//1为一组,-1为另一组 
				q.push(i);
			}
			else if(c[i]==c[now]&&a[now][i])//如果两人在同一组且是朋友 
			return 0;//返0 
		}
	}
	return 1;
}
int dfs(int x)
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		if(!book[i]&&a[x][i])
		{
			book[i]=1;
			if(!match[i]||dfs(match[i]))
			{
				match[i]=x;
				return 1;
			}
		}
	}
	return 0;
 } 
int main()
{
	int x,y,i,j,k;
	while(~scanf("%d%d",&n,&m))
	{
		memset(match,0,sizeof(match));
		memset(a,0,sizeof(a));
		memset(c,0,sizeof(c));
		while(m--)
		{
			scanf("%d%d",&x,&y);
			a[x][y]=1;
		}
		if(n==1||!judge())//如果建不成二分图,或者只有一个人
		{
			printf("No\n");
			continue;
		}
		int sum=0;
		for(i=1;i<=n;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
			sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值