hdu 4004 The Frog's Games(二分最小化最大值)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4004

Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
  
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
  
  
4 11
 

Source


题意:长度为L的河,有n块石头,求最多跳m次(包括端点),使其距离最远的值最小化。。

思路:令条件C(x) := 可以得到距离最远的是x,问题变为求满足C(x)的最小的x。初始化区间是0~L。接下来判断C(x),如果跳过所有的石头的次数大于m或者相邻的距离大于x,则是不满足的。否则,选取离上一个石头最远的作为下一次的起点。

代码:

#include <algorithm>
#include <cstdlib>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cctype>
#include <cmath>
#include <stack>
#include <queue>
#include <list>
#include <map>
#include <set>

using namespace std;

#define clr(x, y)      memset(x, y, sizeof(x))
#define fr(i,n)        for(int i = 0; i < n; i++)
#define fr1(i,n)       for(int i = 1; i <= n; i++)
#define upfr(i,j,n)    for(int i = j; i <= n; i++)
#define dowfr(i,j,n)   for(int i = n; i >= j; i--)
#define scf(n)         scanf("%d", &n)
#define scf2(n,m)      scanf("%d %d",&n,&m)
#define scf3(n,m,p)    scanf("%d %d %d",&n,&m,&p)
#define ptf(n)         printf("%d",n)
#define ptf64(n)       printf("%I64d",n)
#define ptfs(s)        printf("%s",s)
#define ptln()         printf("\n")
#define ptk()          printf(" ")
#define ptc(c)         printf("%c",c)
#define srt(a,n)       sort(a,n)
#define LL __int64
#define pi acos(-1.0)
#define eps 0.00001
#define maxn 500010
#define mod 1000000007
#define inf 100005

int a[maxn];
int l,n,m;

int C(int d)
{
    int cnt = 0;
    int la  = 0;
    int i =  0;
    while(i <= n)
    {
        cnt ++;
        if(cnt > m || a[i] - la > d)  //次数大于m和相邻点的距离大于d的是不满足的
            return 0;
        while(i <= n && a[i] - la <= d)  //贪心选距离上一个点最远的点
            i++;
        la = a[i-1];                     //更新上一次的位置
    }
    return 1;
}

int main()
{
    // freopen("in.txt","r",stdin);
    while(scf3(l, n, m) == 3)
    {
        fr(i, n)
        scf(a[i]);
        a[n] = l;
        sort(a, a+n);
        int lb = 0, ub = l;
        while(ub - lb > 1)
        {
            int mid = (lb + ub) / 2;
            if(C(mid))
                ub = mid;
            else
                lb = mid;
        }
        printf("%d\n", ub);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值