HDU 4004

Problem B

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65768/65768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 14
Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
 
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
 
  
4 11
先讲下大概题意,一只青蛙从河岸要跳到对岸去,河的宽度是L,两岸间有n块石头排成一列相当于桥,青蛙的每一次跳跃必须落在石头上或者是岸上,最多只能跳m次,题目给出从出发点(岸上)到n块石头的距离,要求输出青蛙在满足上述要求的条件下要到达对岸,最少的跳跃能力是多远,即青蛙以每次跳t 远的距离跳跃,最后需要跳x次才能到达对岸,那么我们要尽量地使x接近于m且x<=m,求出此时的t 值。
代码:
 #include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int n,m,d[50500];
int bu(int mid)   //返回当前步宽所需要的最小步数
{
    int i,j,k,l;
    for(i=1,k=l=0;i<n+2;i++)
    {
        l+=d[i]-d[i-1];
        if(l>mid)
        l=d[i]-d[i-1],k++;
    }
    return l>mid?k+2:k+1;
}
int main ()
{
    int l,i,j,k,mid,x,s;
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        for(i=1;i<=n;i++)
        scanf("%d",d+i);
        d[n+1]=l;
        d[0]=0;
        sort(d+1,d+n+1);            //   高效的排序方法(升序)
        for(i=1,j=0;i<n+2;i++)
        j=max(j,d[i]-d[i-1]);    //找出初始的max,min
        i=j;j=l;
        while(i<j)
        {
            mid=(i+j)/2;
            if(bu(mid)<=m)j=mid;
              else i=mid+1;//学长说这里是因为 mid=(i+j)/2存在损失,可是我还是不太懂,不过根据测试数据来看若改为                                          //i=mid,
                                   //测试到最后(10,11,10)会陷入死循环;
      // printf("%d %d %d",i,j,mid);    测试代码
        }
        printf("%d\n",i);
    }
    return 0;
}

转载于:https://www.cnblogs.com/zhanpang/p/5682919.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值