2503 Babelfish 二分 字典树 map容器

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops
 
》》》》》》》》二分法》》》》》》》》》》》》》》
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cstdio>

using namespace std;

struct node
{
	char compare[11];
	char out[11];
}s[110000];

int cmp( const void *a, const void *b )
{
	node *x=( node *)a;
	node *y=( node *)b;
	return strcmp( x->compare, y->compare );
}

void search( char *str, int n )
{
	int low=0, high=n, mid, flag;
	flag=0;

	while( low<=high )
	{
		mid=( low+high )/2;
		if( strcmp( str, s[mid].compare )==0 )
		{
			flag=1;
			printf( "%s\n",s[mid].out );
			break;
		}
		else if( strcmp( str, s[mid].compare )>0 )
			low=mid+1;
		else 
			high=mid-1;
	}
	if( flag==0 )
		printf( "eh\n" );
}

int main()
{
	char str[110];
	char a[110],b[110];

	int n=0;
	while( gets( str ),str[0] )
	{
		sscanf( str,"%s%s",a,b );
		strcpy( s[n].out, a );
		strcpy( s[n].compare, b );
		n++;
	}

	qsort( s, n, sizeof( s[0] ), cmp );

	while( gets( str ) )
	{
		search( str, n-1 );
	}
	return 0;
}


 
《《《《《《《《《《《字典树》》》》》》》》》》》》》》》》
#include <algorithm>
#include <cstring>
#include <cstdio>

using namespace std;

struct node
{
	struct node *son[30];
	char str[110];
};
node *root, *now, *next;

void build( char *str, char *st )
{
	int i, j;
	int len=strlen( str );

	now=root;
	for( i=0;i<len;i++ )
	{
		if( now->son[str[i]-'a']==0 )
		{
			next=( struct node * )malloc( sizeof( struct node ) );
			now->son[str[i]-'a']=next;
			now=next;
			for( j=0;j<26;j++ )
				next->son[j]=0;
		}
		else
		{
			now=now->son[str[i]-'a'];
		}
	}
	strcpy( now->str, st );
}

void search( char *str )
{
	int i, len;
	len=strlen( str );

	now=root;
	for( i=0;i<len;i++ )
	{
		if( now->son[str[i]-'a']==0 )
		{
			printf( "eh\n" );
			return ;
		}
		now=now->son[str[i]-'a'];
	}
	printf( "%s\n", now->str );
}

int main()
{
	int i, j, k, t;
	char str[110];
	char a[110],b[110];

	root=( struct node * )malloc( sizeof( struct node ) );
	for( i=0;i<26;i++ ) root->son[i]=0;

	while( gets( str ),str[0] )
	{
		sscanf( str,"%s%s",a,b );
		build( b, a );
	}

	while( gets( str ) )
	{
		search( str );
	}
	return 0;
}
《《《《map容器《《《《
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <map>
using namespace std;

int main()
{
    char str[101];
    char a[101], b[101];
    map<string,string>q;

    while( gets( str ),str[0] )
    {
        sscanf( str, "%s%s", a, b );
        q[b]=a;
    }
    while( gets( str ) )
    {
        q.count( str )?cout<<q[str]<<endl:cout<<"eh"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值