超大数次幂再求余


H - Super A^B mod C
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given A,B,C, You should quickly calculate the result of A^B mod C. 

(1<=A,C<=1000000000,1<=B<=10^1000000).

Input

There are multiply testcases. Each testcase, there is one line contains 
three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 4
2 10 1000

Sample Output

1
24

某大伽的超级代码

简便代码:

//模拟乘法。将乘法编程二进制加法。

#include <stdio.h>
unsigned __int64 mul (unsigned __int64 a,unsigned __int64 b,unsigned __int64 c)
{
 	unsigned __int64 res=0,tmp=a%c;
	while(b)
 	{
		if(b&1 && (res+=tmp) >= c) 
			res -= c;
		if((tmp <<= 1) >= c) 
			tmp -= c;
		b>>=1;
 	}
	return res;
}

int main(void)
{
	 unsigned __int64 a,b,c,y;
	 while (scanf("%I64u %I64u %I64u",&a,&b,&c)!=EOF)
	 {
		y = 1;
		while(b)
 		{

			if(b&1) y = mul (y,a,c);
			a=mul(a,a,c);
			b>>=1;
 		}
		printf("%I64u\n",y%c);
 	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值