Sum of Square

题目描述

Give you a number named N; please tell me how many ways to arrive N use two square
integers.

输入

There are many of test cases. For each test case, just one line contains a number N
(1<=N<=1000000).
Proceed to the end of file.

输出

If there is no way to arrive N use two square numbers, please output “No Solution!”, and
else output an integer indicating the ways number.

样例输入

50
9

样例输出

2
1
#include<stdio.h>
#include<string.h>
int hash[1000001];
int main()
{
    int a,b;
    for(a=0 ;a<=800 ;a++)
    {
        for(b=a;b<=1000;b++){
             if(a*a+b*b<=1000000)
        {
            hash[a*a+b*b]++;
        }
        else
        {
            break;
        }
    }
    }
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(hash[n]==0)
        {
            printf("No Solution!\n");
        }
        else
        {
            printf("%d\n",hash[n]);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值